Changelog (MIG)
4.2.1
tba
Resolved an issue where the WAR deployment was missing a library.
Fixed a display error occurring on the migration status page.
Corrected the creation date display in the WebUI logs to prevent showing incorrect default dates.
Addressed a bug where the count of running migrations was displayed incorrectly in the monitor.
4.2.0
01.07.2026
Fixed wrong componentID logged under some circumstances.
Removed check preventing stopping migration from other server.
Fixed handling of HTTP/2 headers, especially with transfer-encoding:chunked
Fixed deadlock with SQL-Server databases. (There is no migration of existing instances, only newly created migration file uploads will get the fix.)
4.1.9
21.05.2026
Fixed an error with the build in 4.1.8
4.1.8
15.05.2026
This release was removed due to an error
fixed issue caused by H2 error (https://github.com/h2database/h2database/issues/4107 )
WARNING: Breaking changes! If you are not using a custom database, changes have to be made to the existing H2 database, or existing data will be lost.
Please see H2 Database Migration for documentation of the required changes.
added compatibility to third-party content servers - tolerate Archive Link multipart component headers X-compTimeC and X-compTimeM with, according archive link specification 6.4, page 20, incompatible time values with milliseconds like 12:16:56.016
fix an issue where all entries above DBMaxEntries are not migrated
4.1.7
Due to the change of the underlying container to alpine, the UID has changed from 65533 to 65532.
20.01.2026
add further fallbacks for enhanced compatibility:
strict encoding according to ArchiveLink spec
double encoding as in (a), %2520 however remains %20strict encoding according to AL, but multibyte chars are encoded separately, so %D985 is output as %D9%85
double encoding as in (b), %2520 however remains %20encoding with URLEncoder, but spaces and + are encoded as %20
double encoding as in (c), %2520 however remains %20
4.1.6
02.10.2025
update Proxy to 2.0.4
4.1.5
05.08.2025
Added Webconsole Security Provider
4.1.4
24.02.2025
fix an hash issue during reprocessing
add configuration to add repository in serverInfo
4.1.3
02.09.2024
fix an issue with oracle connections
fix an rare issue with wrong sorting during reprocessing of non kgs sources for documents with multiple components
4.1.2
12.06.2024
add support for additional creation date format: yyyyMMdd and time HHmmss
4.1.1
19.04.2024
removed a bug with Repositories starting with a space
fixed a bug with skipExisting when orgin-datesource was null
fixed a bug where a cleanup was triggered in the destination before a migration
updated versions
smaller fixes (typos etc.)
4.1.0
29.11.2023
datatype is now a mandatatory field
setOriginalDateTime is now default set to truee, existing configurations remain unchanged
datesource in migration reports is now the creation date of the components from source archive
fix an issue that prevents using tia classic ContentServer Version 6.x as target
4.0.0
08.11.2023
Major Release
WARNING: Breaking changes! If you are not using a custom database, changes have to be made to the existing H2 database, or existing data will be lost.
Please see H2 Database Migration for documentation of the required changes.
Change to Jarkata Servlet >= 6.0 - Breaking Change: is only running on modern Java-Webserver that supports JakartaEE (e.g. Tomcat 10 …) and Java 17+
Security-Fixes
3.2.17
28.06.2023
3.2.16
23.06.2023
3.2.15
14.04.2023
3.2.14
28.03.2023